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ABSTRACT

ARTICLE INFORMATION

Crime scene investigators generally have two options when they need to create a three-dimensional (3D)
model of a crime scene: enlist the services of an expert 3D modeller who specializes in graphic modelling or
learn one of the full-fledged modelling tools to create the model themselves. Many modelling tools have a
very steep learning curve, so the time required to invest in learning a tool to get even a simple result is often
prohibitive. In this article, we introduce SketchUp (version 8) as a relatively easy-to-use tool for modelling
crime scenes in 3D, give an example of how the software can be applied, and provide resources for further

information.
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Introduction

Computer graphics have been used to enhance
the visualization of shapes and structures across
a wide variety of disciplines since the 1970s,
when the capability to produce computerized
3D models was first developed [1]. Shortly after
this technological advancement, professionals
in the field of forensics began to utilize
computer modelling techniques to demonstrate
eye-witness accounts and forensic findings
during testimony in court [2-4]. However,
until recently, using computer programs to
model in 3D has generally been a complex
undertaking, usually requiring an expert in
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modelling or computer aided design (CAD) to
produce a meaningful 3D model. As a result,
investigators have been limited in terms of
which scenes they can model in 3D because of
the time-consuming and expensive nature of
the modelling process.

Fortunately, over the last few years, as
investigators have become more comfortable
interacting with computers and graphics
software has become easier to use, new
options have become available to the average
investigator. One tool in particular—SketchUp
(version 8)—has really flattened the learning
curve and made basic 3D modelling available
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to any investigator willing to spend a little time
learning the software.

Crime Scene Graphics

Crime scene graphics are visual designs
intended to illustrate details observed at a
physical location. Such graphics communicate
spatial relationships to those who did not
attend the scene and provide an effective way
to document a scene for subsequent analysis
and presentation. They include basic, hand-
drawn illustrations (commonly called rough
sketches), intricate, detailed drawings (known
as final sketches or diagrams), and interactive,
realistic replicas (referred to as 3D models in
this article).

Typical scene sketches and models
present a two-dimensional (2D), top-down
representation of the scene [5]. While 2D
sketches and models are useful for presenting
the spatial information collected at scenes, 3D
models can be more effective at communicating
such information.

With SketchUp, the authors propose that
investigators who have no professional graphics
training can produce realistic 3D crime scene
models without altering the way they process
the scene and they can even create to-scale 3D
models if sufficient measurements are available.

SketchUp's Background

What is SketchUp, and why is it of interest to
crime scene investigators? SketchUp is a 3D
modelling tool originally developed by @Last
Software in 2000, and acquired by Google in
2006 to provide a tool for building 3D models
for their Earth and Map projects. In June 2012,
the rights to SketchUp were purchased by
Trimble (http://www.trimble.com/). SketchUp
is available for both Mac OS X and Windows.
Users may download a free version of SketchUp
ot purchase the Pro version at http://sketchup.
google.com/download/.

While there are many very impressive 3D
modelling tools currently on the market, a
novice modeller with access to the internet
will find the free version of SketchUp easy to
obtain and easy to learn. This means that an
investigator can learn to create these models
themselves instead of relying on someone who
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may not have even attended the scene. The
cost, ease-of-use, and availability of thousands
of models in the Warehouse database make
SketchUp a great option for investigators who

need to produce 3D models of crime scenes.

Basic SketchUp Concepts

Before jumping into an example of how to
build a 3D model, it is important to understand
some of the basic concepts used in SketchUp.
When SketchUp is started, the user is presented
with a window allowing the selection of a
drawing femplate for the project. Templates
do not change the way SketchUp works; they
simply provide a way to set the default scale,
style, and color for new projects. Any of these
settings may still be changed after the project
is created. SketchUp provides several built-in
templates for both imperial and metric units,
and the user can create and save personalized
templates for future use.

When the user creates a new project, they are
presented a window displaying three axes, which
represent the x, y, and z axes of the Cartesian
coordinate system. SketchUp uses three colors
to represent the different axes: red, green, and
blue. The blue line represents up and down and
the other two make up the ground plane for
the model. Each of the axes have a solid line on
one side of the origin and a dotted line on the
other to help with orientation. These axes act
as guidelines and are used to indicate direction
and rotation, to line up objects, and to provide
a visual cue when moving the virtual camera

around the scene.

The Model and the Camera

A SketchUp model is simply the virtual 3D
world the modeller is creating (the crime scene)
which will contain objects such as furniture,
walls, victims, evidence markers, etc. The
camera moves about this scene, allowing the
user to view objects from any angle. SketchUp
provides tools to pan, zoom, and move about
the scene (these tools are described below).
SketchUp also provides seven standard views
that are helpful in positioning the camera at
specific locations relative to the scene’s axes
and for focusing the camera position on the
center of the scene. These views, accessed
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using the Camera->Standard Views menu, are
Top (Figure 1), Front (Figure 2), Back, Left,
Right (Figure 3), Bottom, and Iso (Figure 4).
Another important aspect to viewing the
scene is choosing the camera projection. There
are three different camera projections available:
Parallel Projection (Figure 5), Perspective
(Figure 6), and Two-Point Perspective. The
default camera setting is Perspective, which
makes items closer to the viewer appear larger
than objects further away. This is a visual
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technique that makes your scene appear 3D
even though it is seen on a 2D computer screen.
Consider a picture straight down some railroad
tracks. The tracks appear to meet at a point
in the distance which is called the vanishing
point. With a Parallel Projection, however, the
apparent depth in the model is removed. This is
especially useful when the modeller would like
to produce a traditional, top-down, 2D sketch
of the scene. Two-Point Perspective uses two
vanishing points instead of one and is not really
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« Figure 1 (top left): Top view

Figure 2 (top right): Front
view

Figure 3 (bottom left): Side
view

Figure 4 (bottom right): Iso
view

« Figure 5 (left): Parallel Pro-
jection

Figure 6 (right): Perspec-
tive
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Figure 7 (top left): Shaded p
with Textures style

Figure 8 (top right): Shaded
style

Figure 9 (bottom left):

Monochrome style

Figure 10 (bottom right): X-
ray style
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useful for crime scene models, so it will not be
discussed here.

The user may also add custom fixed camera
positions by using the Scene Manager window,
accessed using the Window>Scenes menu item.
The plus icon in the upper left corner of the window
will create a tab at the top of the viewing window,
called “Scene 1. Clicking on this tab will always
return the camera to this saved position. The user
can keep moving the camera to a new position, and
repeating the “add scene” operation until the user
has the desired number of camera positions saved.
Established scenes may be renamed, rearranged,
revised, or deleted under the scene manager
window. Selected scenes may be exported as 2D
images, 3D models, or animated “fly-through”

videos (see the Advanced Topics section).
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Styles

One of the ways to change the look of the

model is to change the style that affects the
edges and surfaces (faces) of the scene. The
options in the View>Face Styles menu allow
the user to quickly change the visual style of
the model to include textures (Shaded With
Textures, Figure 7) or just show the surfaces
as colors (Shaded, Figure 8). Two other very
useful styles are the Monochrome style (Figure
9), which removes colors, and the X-ray style
(Figure 10), which makes the entire model
transparent. The authors have found this a
useful tool when creating visually busy scenes
in that it can simplify the appearance of the
model and make different viewing options
available to the modeller for presentations.
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Layers

A key feature of SketchUp is the ability to
organize models into layers, which is a concept
many readers may be familiar with if they have
worked with Photoshop. Items in the scene may
be assigned to different layers created by the
modeller and then the visibility of these layers
may be turned on and off. This is an extremely
valuable tool for the modeller if they need to
temporarily hide an object or objects from
view, either for editing purposes, or because
the modeller needs to draw attention to other
items in the scene. Grouping objects into logical
layers as the model is being built can save a lot
of time when putting together presentations
or trying to demonstrate something using the
model. The user might put all the furniture
in one layer, for example, so it may be easily
hidden to show only the floor plan.

Essential SketchUp Tools

SketchUp provides many tools to manipulate,
view, and work with your model. This article
is not going to examine all of them, but will
introduce the most basic tools used to create,
modify, and view the edges and faces of a
model. SketchUp provides several tools palettes
that may be shown by selecting them in the
View menu. Though most are for special tasks,
the Large Tool Set palette (Figure 11) (accessed
by selecting it from the View>Tool Palettes
menu) contains all of the basic tools needed for
the example presented in this article. When a
basic tool is selected, the status indicator at the
bottom of the window provides instructions for
how to operate it. The question mark icon next
to the status indicator will open the Instructor
window, which is a helpful guide investigators
can use to familiarize themselves with each of
the tools’ basic and advanced operations. The
authors also strongly encourage new users to
take advantage of free tutorials posted on the
SketchUp website (http://www.sketchup.com/
intl/en/training).

The Line, Arc, and Freehand tools allow
the modeller to draw 2D lines. The Line tool
is used to draw a line simply by clicking the
starting point of the line, clicking the endpoint
of the line, and then optionally typing in a
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length (seen in the Measurements box located
in the bottom right corner of the window)
followed by the return key, which will adjust
the line to the length specified. With the Arc
tool, the user clicks the start point of the arc
and the end point, and then, as with the line
tool, may optionally type in a number that
indicates the bulge of the arc. The Frechand
tool lets the user draw arbitrary shapes, which
is converted into a series of lines by SketchUp.

Often the user wants to draw circles,
rectangles, or other regular, multi-sided 2D
shapes. SketchUp provides a way to quickly
draw these primitives using the Rectangle,
Circle, and Polygon tools. To use the Rectangle
tool, the user clicks the location of the first
corner of the rectangle, then clicks the opposite
corner when the rectangle is the correct size.
As with the previous tools, the dimensions may
be entered while the tool is active to set the
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« Figure 11
palette

: Large Tool Set
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dimensions. The Circle tool works the same
way, allowing the modeller to specify the radius
of the circle. Finally, after selecting the Polygon
tool, the user first specifies how many sides in
the shape—3 for a triangle, 5 for a pentagon,
etc.

by typing the number followed by the
return key, clicks the location of the center of
the shape, and finally drags the mouse to the
desired radius. As with all the other tools, the
radius may be specified by typing the radius
followed by the return key.

So far all of these tools allow the modeller
to draw 2D shapes on a specified plane. How
is this translated into 3D? When a 2D shape’s
edges are closed (there are no gaps) SketchUp
shades the surface of the shape to indicate
that it is a face that may now be manipulated.
The Push/Pull tool lets the user click on any
face and push it or pull it using the mouse to
transform a 2D shape into a 3D shape. For this
tool, typing a number will adjust the size of the
shape, allowing the user to make cylinders and
boxes with specific dimensions.

The Offset tool, which the authors find
especially useful in building walls within rooms
and buildings, will copy selected coplanar lines,
and reposition those lines at a uniform distance
from the originals. To use the Offset tool, the
user clicks on a flat face, and then clicks inside
or outside of the original surface to create a
new border defined by the edges of the original
face. As with the other tools, the user can enter
a dimension to set it to a specific distance away
from the original edges.

The Move and Rotate tools move and rotate
2D and 3D figures about the model’s three axes.
In order to look at the other side of the objects
in the scene, the modeller needs to move the
camera. The simplest way to do this is using
the Orbit and Pan tools. With the Orbit tool
selected, clicking and dragging the scene will
rotate the scene as if it were a globe. The Pan
tool picks up and moves the camera without
rotating the scene.

The Scale tool may be used to re-size
and stretch figures relative to the overall
dimensions of the model, while the Dimension
tool will allow the modeller to display the to-
scale length, width, and/or height of an object
with a length precision of 1 /64 inch or 0.039687
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cm. The format of the model’s dimensions
(imperial vs. metric) depends on the default
measurement setting of the template originally
selected when SketchUp was first launched, but
it may be manually adjusted by the user at any
point after the start of the project.

The Tape Measure and Protractor tools let
the modeller measure established distances and
angles, and place guidelines at fixed distances
and angles. These guidelines are particularly
important in that they help a user place objects
at specific locations within the model. To use
the Tape Measure tool, the user clicks on any
edge or endpoint, moves the cursor away from
that point, and clicks again. The Protractor
tool is used in the same manner, except the
user clicks on the vertex of an angle, and then
two locations to identify the legs of the angle
being measured. The Measurements box in
the bottom-right of the window will show
the length or angle between the starting and
ending points specified by the user. The user
can type in a new length if he or she would like
to resize the entire model. The “Control” key
will toggle the guide line feature and instruct
SketchUp to create a guide line at the ending
point of the measurement. The user can then
type in a new length or angle for the accurate
placement of the guide line—a feature that is
particularly useful during the construction of
to-scale models.

The Text and 3D Text tools may be used
to label objects or particular points of interest
in the scene. The Text tool creates 2D text
boxes within the model that may be placed at
stationary locations within the viewport, or
attached to objects within the scene by leader
and a point or arrow. Text created using this
tool shifts as the model is rotated in order to
stay oriented towards the camera. In contrast,
the 3D Text tool produces 2D text tags and 3D
text objects that remain in place as the model is
rotated (Figure 12). The user may edit the size,
color, and font style of text created by either
tool.

The Paint Bucket tool allows the user to
select and apply any solid color or material
stored in the SketchUp materials library. These
materials are abundant and include images of
different types of wood, metal, textiles, and

J Assoc Crime Scene Reconstr. 2012:18(4)



This is a cube

|
\

This is a Tube BN -
\

vegetation. Users may edit any of the pre-
loaded materials or upload new images to add

color and texture to an object in their model.
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The 3D Warehouse

The SketchUp 3D Warehouse is one of the best
benefits of using SketchUp for crime scene
sketching. The 3D Warehouse is a free, online
database containing thousands of models that
have been uploaded by SketchUp users since
2006. SketchUp users may access the database
(http://sketchup.
com/3dwarehouse/) or through the SketchUp
program under File>Warehouse>Get Models.

through the online site

Then it is simply a matter of doing a keyword
search for an object the modeller would like to
import into their sketch. For example, a search
for the word couch will return thousands of
models of couches, loveseats, and chairs that a
modeller can download (Figure 13).

The sophistication of the objects within the
3D Warehouse vary quite a bit, so a modeller
may have to spend several minutes hunting for
the right object for their model. Once objects
have been imported into the scene, they may
be resized and edited as needed. The 3D
Warehouse is constantly being updated with
new models from the SketchUp community,
so it is always a good first stop if a modeller
needs to add something to their crime scene.
Adding models to the 3D Warchouse is also

l=

e

« Figure 12: 2D and 3D Text.
Note that the 3D text
remains on the surface
whereas the 2D text
rotates to face the camera.

« Figure 13: Screenshot
of search results within
Warehouse.
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Result Page:

Results 1 - 12 of many for couch (0.2 seconds)

Green Couch

by ajberger
Green Couch

Download Model

Couch 2

by Joseph Briggs
A detailed couch.

Download Model

Curl lounge couch
by Google

A cushy lounge couch with
Download Model

Tufted couch

by Google

A modern style clack leather.
Download Model

Modern couch 83 x 35
by Google

A modern style couch with...
Download Model

.9

Stuffed modern couch
by Google

A modern style couch with 2...
Download Model

Couch - Home Furniture
by MrCAD

Couch - Home Furniture...
Download Model

%

couch sofa suite

by athrax

A black soft couch complete.
Download Model
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Figure 14: View from the p
kitchen door into the
kitchen.

Figure 15: View of thep
dining room through to the
kitchen.

& WWW.ACSR.ORG J Assoc Crime Scene Reconstr. 2012:18(4)




possible. If an investigator creates a model of
something from a crime scene which might
be useful to others, it is simple to add it to
the 3D Warchouse for other investigators and
SketchUp users.

Scene Example

To present an example of how one might
build 2 3D model from a 2D sketch of a
crime scene, the authors have chosen a small
two-room scene from a homicide in Reading,
14 and 15).
Two males entered a residence armed with

Pennsylvania, USA (Figures

a hammer and a baseball bat and struck the
victim approximately 23 times about the head
and body. The assault started in the kitchen
and ended in the dining room, with the victim
ending up in the doorway between the two
rooms. Detectives subsequently sketched the
scene by hand and documented the scene with
alaser measuring tool and a tape measure using
the baseline method.

Two hand-drawn sketches from the crime
scene (Figure 16) were used to build the 3D
model in SketchUp. Measurements of window
openings, doorways, evidence locations, body
measurements, and some of the furniture
were recorded on separate sheets and are not
presented here.

Before outlining the steps that were taken
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- it is important to note that the steps and

methods presented for this example are just
one way of building a 3D crime scene model
using SketchUp. There are many other tricks
and techniques that may work better for a
given modeller, so users are encouraged to
experiment to find a workflow that suits them.
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<« Figure

16: Hand-drawn

sketches of the kitchen

(left)
(right).

<« Figure

and dining room

17: Importing the

2D hand-drawn sketches
into SketchUp.
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Figure 18: Using thep
Rectangle, Offset, Eraser,
and Dimension tools.
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Importing The Rough Sketches

A new project was created by opening
SketchUp and choosing the Plan View - Feet
and Inches template. Next, scanned copies of
the hand-drawn sketches were imported and
placed in the x-y plane (the top-down view) as
a reference while building the model (Figure
17). This provides a reference so the user does
not have to switch between programs to look
at the sketch, and permits a side-by-side visual

comparison as the user is modelling.

Room Outline

An outline of the rooms was created corresponding
to the measurements from the sketch. Using
the Rectangle tool, the floor was added with the
specified dimensions. The Offset tool was then
used to add thickness to the walls and the Eraser
tool used to create the doorway. Finally, the
Dimension tool was used to add the dimensions of
each room to the model (Figure 18).
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Kitchen
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Adding Furniture

For each piece of furniture in the room, a
search was conducted using the 3D Warchouse
to find furniture that closely matched the
actual furniture in the crime scene photos.
Any furniture that was not found online was
modelled separately and then imported into
the scene. The size and colors of the objects
were adjusted to match the dimensions and
colors of the physical objects and the objects
were placed in the correct location based on the
measurements from the crime scene (Figure

19).

Markers & Guidelines

Guidelines are instrumental for placing objects
at known locations in the scene. For each
evidence location, the Guideline tool was used
to measure and mark the location within the
scene and then a model of an evidence marker
model was positioned accordingly (Figure 20).

J Assoc Crime Scene Reconstr. 2012:18(4)
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« Figure 19: Top-view of
scene after furniture is
added.

« Figure 20: Using the
Guideline tool to position
evidence markers.
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Figure 21: Adjusting the »
control points to pose a
muryoung model.
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Keeping in mind that the investigator probably
does not want the evidence markers visible
all the time, the markers wetre created on a
separate layer within the model, which allows
the user to hide them using the Layers window.

The Body

Placing a body or bodies in a 3D model can
be challenging. One method is to use other
software, such as SmithMirco’s Poser (http://
poset.smithmicro.com), to build the model
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and then to import it into the SketchUp crime

scene. For this example, however, the authors
used the Muryoung Standard_Pose posable
body found in the 3D Warchouse (search for
“muryoung”) and reference photos from the
scene to create a model of a body in the correct
pose. The muryoung model was built in such a
way that control points on the body may be used
to pose it in the correct orientation and then
these control points, which are on a separate
layer, may be hidden in the final presentation
(Figures 21 through 23). Some modellers prefer
to work with models like this in a separate
SketchUp file and then import them into their
main crime scene model, as the authots have
done here. Using separate files may also be
useful if there are multiple people collaborating

on creating one crime scene model.

The Walls

Now that all the objects were placed within the
scene, the next step was to use the Offset, Push/
Pull, and Eraser tools to create the walls of
the dining room and kitchen. Some modellers

41

<« Figure 23: Body imported
and placed in the crime
scene model (note that
the control points layer has
been hidden).

<« Figure 24: Adding walls to
the model.
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Figure 25: Adding detail to p
the model.
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prefer to do this step at the beginning when
they build the outline of the room and then
hide the walls using layers, but in this instance
the modeller added them towards the end of
construction (Figure 24).

Adding Detail

At this point, the main part of the model was
complete, so the final step was to add some
extra detail. For this example, the windows and
doors were added and textures added to the

floor, furniture, and other surfaces (Figure 25).

Different Views

Once the investigator has completed their
model, there are many options for viewing it
and displaying it to others. As discussed earlier,
there are several built-in camera views that the
user can select from the Camera>Standard
Views menu. One of the most useful is obviously
the top-down, or birds-eye, view. The camera
projection may also be chosen in the Camera
menu to show something like an architectural
floor plan without perspective (Figure 26) or a
3D perspective view (Figure 27).

Final Results

The final model can now be compared directly
with photos from the crime scene by moving
the camera around the scene using the Orbit,
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Pan, and Zoom tools. These camera locations
may be saved using the Scene Manager,
described earlier, so they can be accessed with
a simple click when the investigator needs to
present their model and may also be used for
simple animated walkthroughs of the scene
(see the Advanced Topics section).

Any view of the scene may be exported as
a 2D image, like a snapshot from the virtual
camera, using the File>Export>2D Graphic
menu item. SketchUp will save these images
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« Figure 28

(top  left):
Photograph of kitchen.

Figure 29 (bottom left):
View within  SketchUp
model corresponding with
view captured in photo-
graph displayed as Figure
28.

Figure 30 (top
Photograph of body.

right):

Figure 31 (bottom right):
View within  SketchUp
model corresponding with
view captured in photo-
graph displayed as Figure
30.

« Figure 32: Photograph of
body.

Figure 33: View within
SketchUp model corre-
sponding with view cap-
tured in photograph dis-
played as Figure 32.
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in JPEG, PNG, ofr TIFF format. For each of the
reference photos, the camera was placed in
approximately the same location and the
images exported from SketchUp (Figures 28

through 33).

Advanced Topics

This article has introduced some of the basic
concepts, tools, and functionality available
in SketchUp. There are several other, more
advanced, capabilities that have not been
covered but may be of interest to users after
they become familiar the basic capabilities of

SketchUp.

Photography

As discussed in the introduction, the level of
realism of a model can vary dramatically. With
photography, the type and number of photos
may depend on whether the investigator is
planning to build a more sketch-like 3D model
or whether they aim to build a to-scale realistic
rendering of the scene. If the investigator is
intending to build a more realistic model, then
representative texture photos of walls, floors,
furniture, and other objects in the scene should
be shot so they may be used within SketchUp
to texture the models.

Regardless of the level of realism planned,
it is always helpful to have numerous reference
photos of the scene from different angles
and positions. These will be instrumental in
positioning objects, setting colors, and choosing
models from the 3D warehouse to represent
furniture and other objects in the scene. If a
model of a specific object is not available in
the 3D Warehouse, then the investigator may
have to create their own, so, in addition to the
measurements, reference photos are essential.
If there are bodies to be documented and
placed in the model, then photos will be crucial
for posing the body model in SketchUp; thus it
is highly advisable to take many photos from
different angles.

Scene Animation

Using the Scene Manager discussed earlier,
the user can add several camera positions
throughout the scene. To see the animation,
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the user right-clicks a scene tab and selects Play
Animation. SketchUp will cycle through all
saved camera views, starting from the scene tab
that was selected. The time it takes the camera
to transition from scene to scene may be edited
under the Animation section of the Model Info
window located under Window>Model Info.
When the user is satisfied with the movement
of the camera from the first scene to the last
scene, they can export the animation as an
Audio Video Intetleaved (avi) file. This file
may be opened with an audio/video player like
Windows Media Player or QuickTime. This
animation might be used to virtually “walk”

someone through a crime scene.

Extending SketchUp

Plug-ins, optional software add-ons that allow
users to automate tasks and add capabilities
to SketchUp, can either be written using a
programmer’s interface and a language like
C++ or using a scripting language called
Ruby. Plug-ins are available for both SketchUp
and SketchUp Pro and are a great way to add
features to SketchUp that are not included as
part of the basic software.

A good example—one that may be useful
for crime scene presentations—is the free
Advanced Camera Tools plug-in created for
SketchUp  Pro  (http://sketchup.com/intl/
en/download/plug-ins.html#advcam).  This
provides more refined control of the camera,
allowing adjustment of focal length and other
physical camera settings, that can help the user
create views of their 3D model that more closely
resemble a physical photo for comparison.

While plug-ins are not required to complete
a high-quality crime scene model, users are
encouraged to explore the sites listed in the
Supplemental Materials section below, as they
will find useful plug-ins like 3D Grid and
Toggle Units. CubicPanoOut is an especially
interesting plug-in that works in conjunction
with a panoramic image converter like
Garden Gnome Software’s Pano2VR (http://
gardengnomesoftware.com/pano2vr.php)
to create virtual 3D panoramic tours of the
SketchUp model.

There are many other plug-ins that are
available for a fee, which help more advanced
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users of SketchUp create photorealistic
renderings of a SketchUp model. Twilight
Render  (http://twilightrender.com/)  and
LightUp for SketchUp (http://www.light-up.
co.uk/) are two examples of rendering plug-
ins that give the modeller precise control over
lighting and shadows, which can help when
presenting 3D models of crime scenes.

Using SketchUp With Other Tools

SketchUp provides capabilities that allow
the user to import models created in other
software or export their crime scene model for
use in another program. Some types of model
might be easier to create in other software
such as 3ds Max (http://autodesk.com/3ds-
max) or Blender (http://blender.org), or they
might be generated by other software such as
FORident Software’s HemoSpat, a bloodstain
pattern analysis application (http://hemospat.
com). These may be saved in one of several file
formats, imported into SketchUp, and placed in
the user’s crime scene model. Similarly, using
SketchUp may be an intermediate step in a
uset’s process and the models may be exported
to a variety of formats for import into other

programs.

SketchUp vs. SketchUp Pro

While the free version of SketchUp is a
powerful tool, there are several features in
SketchUp Pro that give users more flexibility
when creating 3D crime scene models and can
make the process easier. Some of the features
include capabilities to extend SketchUp, for
example plug-ins and additional file formats
for importing and exporting data and some
add completely new capabilities like the report
generation and integration with the LayOut
application.

Import and Export

The free version of SketchUp supports
importing of 3ds Max (.3ds) files, COLLADA
(dae) files, Earth (kmz), and digital elevation
model (dem) files. For 3D models, SketchUp
will export to COLLADA or Earth formats.
COLLADA is an emerging standard used to
share 3D information between applications.
One drawback, however, is that COLLADA
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support varies greatly between applications and
sometimes materials, textures, or animations
applied to a model in one application get lost in
the translation.

SketchUp Pro adds support for importing
and exporting a wider range of 2D and 3D
file formats such as AutoCAD (.dxf and .dwg),
Autodesk FBX Technology (fbx), and others
that are already standard in the CAD and
modelling industry.

Attribute Report

SketchUp Pro has a report generator that can
be invaluable for demonstrating accuracy of
models in court. The report generator creates
an attribute report that lists each component
in the model, along with its x-y-z location and
dimensions. To make this report useful, it is
good practice to group and make components
of objects and to save them on separate layers
while creating the model. The report may be
saved as an HTML file, suitable for a web
browser or a comma-separated values (CSV)
file that may be viewed in spreadsheet software
such as Microsoft Excel or LibreOffice Calc. To
make the CSV report easier to read, columns
may be re-labelled to better describe what they
represent. For example, the report displays
“LenX” (length in X axis), “LenY” (length in
Y axis), and “LenZ” (length in Z axis). Once
imported into the spreadsheet software, these
titles may be renamed to something more
user-friendly (e.g. “Length”, “Width”, and
“Height”). Providing this computer-generated
report along with the sketch measurements
demonstrates that the model is based on real

world measurements.

LayOut

LayOut (http://sketchup.com/intl /en/product/layout.
html)is an application that comes with SketchUp
Pro that takes 3D models and turns them into
high-definition 2D images. LayOut is useful
when creating slideshows of a 3D model, fly-
through animations, or simply to display a
2D drawing of a crime scene model. While
the free version of SketchUp allows printing
of models, the resolution is limited to screen
resolution that limits the ability to mount large
scale models. LayOut removes this limitation
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Figure 34: The Schade Body »
posed for the example
crime scene.
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and allows printing high quality vector or
raster images of a 3D model. LayOut is fully
integrated with SketchUp Pro, so any changes
made to the model in SketchUp will be reflected

automatically in the LayOut presentation.

Resources

There are numerous resources available, not
only to learn to use SketchUp, but also to
provide models for thousands of objects the
modeller can add to their crime scene model.
Trimble has a web page devoted to SketchUp
resources which is a good place to start (http://
sketchup.com/intl/en/community/resources.
html).

Tutorials

New users should probably start with Trimble’s
online video tutorials. These cover a wide
range of topics from an introduction to basic
concepts to advanced topics, such as using
photo matching to create models (http://
sketchup.com/training/videos.html). ~ Many
SketchUp users have also uploaded their own
tutorials onto video forums like YouTube.
New users are encouraged to explore these
free services when first learning how to use

SketchUp.

Models

As mentioned in the section above, the
SketchUp 3D Warchouse provides tens of
thousands, if not hundreds of thousands, of
pre-built models. This is a goldmine for an
investigator trying to quickly model a room in
a house (http://sketchup.com/3dwarehouse/).

SketchUp also imports other model formats,
so if a user finds the exact model they are
looking for they can likely import it and use
it in their scene. There are many websites that
offer free-to-use models that may be suitable
for a user’s crime scene model.

Although they were not used in the example for
this article, one of the authors has built two new
body models—one male, one female—that offer a
lot of control of the joints to help position bodies in
a scene (Figure 34). These models may be found in
the 3D Warehouse by searching for “Det Schade”.
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Plug-ins

As mentioned in the Advanced Topics section
above, plug-ins provide a great way to extend
the capabilities of SketchUp. Trimble provides
a range of free and commercial plug-ins
(http://sketchup.com/intl/en/download/plug-
ins.html) and some third-parties also develop
and sell plug-ins. This web page also has links
to several other websites that provide plug-ins.

Two other good sources for plug-ins are
Smustard (http://smustard.com) and the Ruby
Library Depot (http://rhin.crai.archi.fr/rld/
index.php).

Looking at examples of plug-ins written in
Ruby might be useful for any users wanting
to create their own custom plug-ins. Trimble
provides some sample Ruby scripts available to
get users started (http://sketchup.com/intl/en/
download/rubyscripts.html).

Conclusion

Creating 3D crime scene models has typically
been  expensive and  time-consuming.
SketchUp, while not specifically designed for
crime scene work, is a tool that provides crime
scene investigators a relatively simple and cheap
alternative to create their own 3D models. This
article presented the basic tools and concepts
necessary for working with SketchUp and
provided an end-to-end example, taking a 2D
crime scene sketch and creating a 3D model.
The authors hope that this introduction
gives investigators an idea of what is possible

with SketchUp and enough information and
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resources so that they can start working with
SketchUp to produce their own 3D crime scene
models.
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Supplemental Material

The following files are included in the

supplemental material:

e  Example Scene.skp—the complete Sketch-
Up model for the crime scene example
used in this article.

*  Muryoung body—Posed.skp — the SketchUp
file for the muryoung body model posed for

the example crime scene in this article.

*  Schade body—Posed.skp—the SketchUp file
for the new male body model, mentioned
in the Resources section, posed for the
example crime scene in this article.
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